Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)




"Thank God for your Data Feed as the only Zippers I see are on my pants (LOL), and no more 200 pip spikes to mess up charts." - Comment from Spiro via Email
"I have been using IQFeed now for a few years in MultiCharts and I have zero complaints. Very, very rare to have any data hiccups or anything at all go wrong." - Comment from Public Forum
"The people at Nirvana have very nice things to say about your company and I can see why! Price and service is a potent combination." - Comment from Ed
"I noticed that ******* quotes locked up shortly after the interest rate announcement yesterday while yours stayed stable." - Comment from Ron in Utah
"I am enjoying the feed very much - so superior to the broker provided feed I was previously using." - Comment from George
"You are much better than lawyers or the phone company because you answer the phone when I call! I just love your customer service." - Comment from Isreal
"I just wanted to let u know that your data feed/service is by far the best!!! Your unfiltered tick data is excellent for reading order flow and none of your competitors delivers this quality of data!" - Comment from Peter via Email
"I am very pleased with the DTNIQ system for quotes and news." - Comment from Larry
"I was with ******* for 4 years at $230 a month, this is a huge savings for me, GOD BLESS YOU PEOPLE," - Comment from T.S. via Email
"IQ feed works very well, does not have all of the normal interruptions I have grown used to on *******" - Comment from Mark
Home  Search  Register  Login  Recent Posts

Information on DTN's Industries:
DTN Oil & Gas | DTN Trading | DTN Agriculture | DTN Weather
Follow DTNMarkets on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
»Forums Index »Product Support »Data and Content Support »As of 3/14 some market symbols are "invalid"
Author Topic: As of 3/14 some market symbols are "invalid" (7 messages, Page 1 of 1)

programmer
-Interested User-
Posts: 35
Joined: Feb 3, 2010


Posted: Mar 20, 2019 09:09 AM          Msg. 1 of 7
On March 14 all of a sudden I'm getting a lot of "Invalid symbol" errors. For example pulling history for "APPS" returns invalid symbol even though it's not. I'm not sure if they're all NASDAQ but many of them seem to be.

Maybe I need to update my IQFeed client because I think I'm out of date or maybe my machine has been corrupted.

I'm looking in to the issue on my side but figured I would post to ask if something changed.

DTN_Stephen
-DTN Evangelist-
Posts: 198
Joined: Aug 22, 2014


Posted: Mar 20, 2019 10:02 AM          Msg. 2 of 7
I ran a check on our history for APPS and do not see any issues.

Please feel free to contact us at support@iqfeed.net or join us in chat from www.iqfeed.net with your Login information so that we can research your account.

Stephen Shockey
Customer Support Representative

DTN
800-779-7299
stephen.shockey@dtn.com

9110 W Dodge Rd
Omaha NE 68114, USA
www.dtn.com

programmer
-Interested User-
Posts: 35
Joined: Feb 3, 2010


Posted: Mar 20, 2019 04:09 PM          Msg. 3 of 7
Thanks for checking. Seems to be working fine now during the day but I just updated from 6.0.0.5 to 6.0.1.1 so I'll see how that goes tonight too.

Looking at version 6.0.1.1 I see: Added support for 64bit (8+ decimals) precision prices in streaming (Level 1) data and History data (as soon as the history servers support rolls out).

Any chance the history servers updated to this new 64bit precision on March 14?

Just trying to figure out what happened. I'll keep testing to make sure the problem is not on my side.

DTN_Steve_S
-DTN Guru-
Posts: 2094
Joined: Nov 21, 2005


Posted: Mar 21, 2019 07:47 AM          Msg. 4 of 7
No, the history servers were updated quite a while ago (at least a couple weeks before that). I'll get the release notes updated to indicate that has been completed.

DTN_Steve_S
-DTN Guru-
Posts: 2094
Joined: Nov 21, 2005


Posted: Mar 21, 2019 07:53 AM          Msg. 5 of 7
I just realized something not-quite right here.

A long while back (at least a year or two), the history servers stopped sending the Invalid Symbol error code so there is no way you should have been getting that specific error. Are you certain this is the case? If so, please let me know your loginID so I can look at the server logs. Feel free to send it to me in a PM or an email to dev support.

DTN_Steve_S
-DTN Guru-
Posts: 2094
Joined: Nov 21, 2005


Posted: Mar 21, 2019 08:04 AM          Msg. 6 of 7
OK, another update. After searching through the server logs a bit, it appears that this error has been re-implemented for obviously bad symbols (stuff not allowed by our symbology).

However, with that said. There were only 13 requests total on March 14th that returned this error and none of them were for valid symbols.

programmer
-Interested User-
Posts: 35
Joined: Feb 3, 2010


Posted: Mar 21, 2019 08:12 AM          Msg. 7 of 7
After digging in to it, that error is actually one of my internal errors and kind of generic (ie. it can be caused by a number of things). I'm not sure what the IQ client is returning but I am running the latest now 6.0.1.1.

I'm still investigating this. I have a lot of things I need to upgrade including the OS. I managed to get some history pulls yesterday without errors so it obviously CAN work. I'm thinking the problem is probably on my side. Though I'm not sure why this started all of a sudden. Anyway, I'm going to rework some of my code making that error less generic so I can see was is going on in case this happens again.

Thanks for the help!
 

 

Time: Thu September 19, 2019 5:17 AM CFBB v1.2.0 15 ms.
© AderSoftware 2002-2003